Mails unable to be delivered to @cyberwolvesnet.com accounts.

February 24, Sun
Affected Service: E-Mail Service
  • Investigating
    Recently we've noticed a lot of emails being unable to be delivered towards any domain ending in @cyberwolvesnet.com. We've got in touch with CloudWebServices and are working together to fix this.

    14:49, Feb 18 UTC
  • Update
    It appears that the spamfilter Blacklists a lot of email going to the @cyberwolvesnet.com domain and marks other emails as spam. We're currently working out for a bypass

    15:10, Feb 18 UTC
  • Testing
    After almost a week we've finally come with a fix and are now testing to see if it works.

    14:24, Feb 24 UTC
  • Resolved
    We'll now mark this as resolved until further notice

    14:25, Feb 24 UTC
Back to current status